<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />

<!-- Open Graph Meta Tags generated by MashShare 3.7.6 - https://mashshare.net -->
<meta property="og:type" content="article" /> 
<meta property="og:title" content="Will The Hummer EV Be The New Favorite For RVers?" />
<meta property="og:description" content="Could the GMC Hummer EV be the new favorite truck of RVers? With loads of torque, space, and capability, RVers may turn to Hummer for their next truck." />
<meta property="og:image" content="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-8.58.50-AM.png" />
<meta property="og:url" content="https://rvlife.com/hummer-ev/" />
<meta property="og:site_name" content="RV LIFE" />
<meta property="article:publisher" content="https://www.facebook.com/RV-LIFE-Magazine-28544971170/" />
<meta property="fb:app_id" content="863082490488838" />
<meta property="article:published_time" content="2020-10-21T16:55:38+00:00" />
<meta property="article:modified_time" content="2020-10-21T18:52:41+00:00" />
<meta property="og:updated_time" content="2020-10-21T18:52:41+00:00" />
<!-- Open Graph Meta Tags generated by MashShare 3.7.6 - https://www.mashshare.net -->
<!-- Twitter Card generated by MashShare 3.7.6 - https://www.mashshare.net -->
<meta property="og:image:width" content="2000" />
<meta property="og:image:height" content="1108" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Will The Hummer EV Be The New Favorite For RVers?">
<meta name="twitter:description" content="Could the GMC Hummer EV be the new favorite truck of RVers? With loads of torque, space, and capability, RVers may turn to Hummer for their next truck.">
<meta name="twitter:image" content="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-8.58.50-AM.png">
<meta name="twitter:site" content="@rvlifemagazine">
<!-- Twitter Card generated by MashShare 3.7.6 - https://www.mashshare.net -->


<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var gtm4wp_datalayer_name = "dataLayer";
	var dataLayer = dataLayer || [];
//]]>
</script>
<!-- End Google Tag Manager for WordPress by gtm4wp.com -->
	<!-- This site is optimized with the Yoast SEO Premium plugin v14.6.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Will The Hummer EV Be The New Favorite For RVers?</title>
	<meta name="description" content="Could the GMC Hummer EV be the new favorite truck of RVers? With loads of torque, space, and capability, RVers may turn to Hummer for their next truck." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://rvlife.com/hummer-ev/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Will The Hummer EV Be The New Favorite For RVers?" />
	<meta property="og:description" content="Could the GMC Hummer EV be the new favorite truck of RVers? With loads of torque, space, and capability, RVers may turn to Hummer for their next truck." />
	<meta property="og:url" content="https://rvlife.com/hummer-ev/" />
	<meta property="og:site_name" content="RV LIFE" />
	<meta property="article:publisher" content="https://www.facebook.com/pages/RV-Life-Magazine/28544971170" />
	<meta property="article:published_time" content="2020-10-21T21:55:38+00:00" />
	<meta property="article:modified_time" content="2020-10-21T23:52:41+00:00" />
	<meta property="og:image" content="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-8.58.50-AM-1024x567.png" />
	<meta property="og:image:width" content="1024" />
	<meta property="og:image:height" content="567" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:title" content="Will The Hummer EV Be The New Favorite For RVers?" />
	<meta name="twitter:description" content="Could the GMC Hummer EV be the new favorite truck of RVers? With loads of torque, space, and capability, RVers may turn to Hummer for their next truck." />
	<meta name="twitter:image" content="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-8.58.50-AM.png" />
	<meta name="twitter:creator" content="@RVLifeMagazine" />
	<meta name="twitter:site" content="@RVLifeMagazine" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://rvlife.com/#website","url":"https://rvlife.com/","name":"RV LIFE","description":"Tools That Make Camping Simple","potentialAction":[{"@type":"SearchAction","target":"https://rvlife.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://rvlife.com/hummer-ev/#primaryimage","inLanguage":"en-US","url":"https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-8.58.50-AM.png","width":2000,"height":1108,"caption":"GMC Hummer EV"},{"@type":"WebPage","@id":"https://rvlife.com/hummer-ev/#webpage","url":"https://rvlife.com/hummer-ev/","name":"Will The Hummer EV Be The New Favorite For RVers?","isPartOf":{"@id":"https://rvlife.com/#website"},"primaryImageOfPage":{"@id":"https://rvlife.com/hummer-ev/#primaryimage"},"datePublished":"2020-10-21T21:55:38+00:00","dateModified":"2020-10-21T23:52:41+00:00","author":{"@id":"https://rvlife.com/#/schema/person/84ed216a2bd0c1dd57fc09b17140ed4c"},"description":"Could the GMC Hummer EV be the new favorite truck of RVers? With loads of torque, space, and capability, RVers may turn to Hummer for their next truck.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://rvlife.com/hummer-ev/"]}]},{"@type":["Person"],"@id":"https://rvlife.com/#/schema/person/84ed216a2bd0c1dd57fc09b17140ed4c","name":"Patrick Buchanan","image":{"@type":"ImageObject","@id":"https://rvlife.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ed532b8c60fc99d551af30cc9c219dd5?s=96&r=g","caption":"Patrick Buchanan"},"description":"All around RV enthusiast who enjoys trips with his wife and little dogs in their 43-foot diesel pusher."}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//scripts.mediavine.com' />
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//a.omappapi.com' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="RV LIFE &raquo; Feed" href="https://rvlife.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="RV LIFE &raquo; Comments Feed" href="https://rvlife.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="RV LIFE &raquo; Will The Hummer EV Be The New Favorite For RVers? Comments Feed" href="https://rvlife.com/hummer-ev/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/rvlife.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.7"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='sb_instagram_styles-css'  href='https://rvlife.com/wp-content/plugins/instagram-feed/css/sbi-styles.min.css?ver=2.5' type='text/css' media='all' />
<link rel='stylesheet' id='milan-pro-css'  href='https://rvlife.com/wp-content/themes/milan/style.css?ver=1.1.0' type='text/css' media='all' />
<style id='milan-pro-inline-css' type='text/css'>

		.site-header,
		.single .entry-title:before,
		.comment-reply-title  {
			background-color: #d92231;
		}

		.archive-pagination a,
		.site-main #infinite-handle span button,
		.site-main #infinite-handle span button:hover,
		.site-main #infinite-handle span button:focus,
		.archive-pagination a:before,
		#infinite-handle button:before,
		.main-navigation a,
		.byline a,
		.cat-links a,
		.entry-content a,
		.featured-primary .entry-excerpt a,
		.post-navigation .nav-links a,
		.comment-navigation a,
		.comment-content a,
		.comment-form a,
		.comment-author span[itemprop="name"] a,
		.widget a,
		.site-footer p a,
		.breadcrumb a,
		.featured-row {
			border-color: #d92231;
		}
		

		.site-header {
			background-image: url( 'https://rvlife.com/wp-content/uploads/2019/09/header-bg.jpg' );
		}
</style>
<link rel='stylesheet' id='wp-block-library-css'  href='https://rvlife.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='cff-css'  href='https://rvlife.com/wp-content/plugins/custom-facebook-feed/css/cff-style.css?ver=2.17' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='sb-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=5.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='mashsb-styles-css'  href='https://rvlife.com/wp-content/plugins/mashsharer/assets/css/mashsb.min.css?ver=3.7.6' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#cccccc;}@media only screen and (min-width:568px){.mashsb-buttons a {min-width: 177px;}}
</style>
<link rel='stylesheet' id='ez-icomoon-css'  href='https://rvlife.com/wp-content/plugins/easy-table-of-contents/vendor/icomoon/style.min.css?ver=2.0.7' type='text/css' media='all' />
<link rel='stylesheet' id='ez-toc-css'  href='https://rvlife.com/wp-content/plugins/easy-table-of-contents/assets/css/screen.min.css?ver=2.0.7' type='text/css' media='all' />
<style id='ez-toc-inline-css' type='text/css'>
div#ez-toc-container p.ez-toc-title {font-size: 120%;}div#ez-toc-container p.ez-toc-title {font-weight: 500;}div#ez-toc-container ul li {font-size: 95%;}div#ez-toc-container {width: 100%;}
</style>
<link rel='stylesheet' id='mashnet-styles-css'  href='https://rvlife.com/wp-content/plugins/mashshare-networks/assets/css/mashnet.min.css?ver=2.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='mashpv-css'  href='https://rvlife.com/wp-content/plugins/mashshare-pageviews/assets/css/mashpv.min.css?ver=1.1.5' type='text/css' media='all' />
<link rel='stylesheet' id='mashresp-styles-css'  href='https://rvlife.com/wp-content/plugins/mashshare-responsive/assets/css/mashresp.min.css?ver=2.0.7' type='text/css' media='all' />
<style id='mashresp-styles-inline-css' type='text/css'>

        @media only screen and (max-width: 568px){
            .mashsb-buttons a {
                width: 41px;
            }
        }
        @media only screen and (max-width: 568px){
            [class^="mashicon-"] .text, [class*=" mashicon-"] .text {
                display: none;
            }
        }
</style>
<link rel='stylesheet' id='mashbar-css'  href='https://rvlife.com/wp-content/plugins/mashshare-sharebar/assets/css/mashbar.min.css?ver=5.2.7' type='text/css' media='all' />
<style id='mashbar-inline-css' type='text/css'>

            #mashbar-header{
            top: 0px; 
            }
            #mashbar-header{
            background-color: #ffffff;
            z-index: 999999;
            }
        @media (min-width: 630px) {
    #mashbar-header .mashbar-inner {
    max-width: 660px;
    margin: 0 auto;
    }
}
</style>
<link rel='stylesheet' id='mashvipo-css'  href='https://rvlife.com/wp-content/plugins/mashshare-videopost/assets/css/mashvipo.min.css?ver=1.4.6' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Playfair+Display%3A400%2C400italic%2C700%2C700italic%7CRoboto%3A100%2C300italic%2C300%2C400italic%2C700%2C700italic&#038;ver=1.1.0' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css?ver=5.2.7' type='text/css' media='all' />
<link rel='stylesheet' id='algolia-autocomplete-css'  href='https://rvlife.com/wp-content/plugins/search-by-algolia-instant-relevant-results/includes/../css/algolia-autocomplete.css?ver=2.11.3' type='text/css' media='screen' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://rvlife.com/wp-content/plugins/jetpack/css/jetpack.css?ver=7.7.3' type='text/css' media='all' />
<script type='text/javascript' src='https://rvlife.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://rvlife.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20190204'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashsb = {"shares":"25","round_shares":"1","animate_shares":"0","dynamic_buttons":"0","share_url":"https:\/\/rvlife.com\/hummer-ev\/","title":"Will+The+Hummer+EV+Be+The+New+Favorite+For+RVers%3F","image":"https:\/\/rvlife.com\/wp-content\/uploads\/2020\/10\/Screen-Shot-2020-10-21-at-8.58.50-AM.png","desc":"Could the GMC Hummer EV be the new favorite truck of RVers? With loads of torque, space, and capability, RVers may turn to Hummer for their next truck.","hashtag":"rvlifemagazine","subscribe":"content","subscribe_url":"","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"0","nonce":"189875d70f","postid":"63130","servertime":"1603403483","ajaxurl":"https:\/\/rvlife.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/mashsharer/assets/js/mashsb.min.js?ver=3.7.6'></script>
<script type='text/javascript' async="async" data-noptimize="1" data-cfasync="false" src='https://scripts.mediavine.com/tags/rv-life.js?ver=5.2.7'></script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/duracelltomi-google-tag-manager/js/gtm4wp-form-move-tracker.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/mashshare-google-analytics/assets/js/mashga.min.js?ver=1.0.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashnet = {"body":"Check out this article from RV LIFE Magazine:","subject":"Check out RV LIFE","pinterest_select":"0","pinterest_image":"https:\/\/rvlife.com\/wp-content\/uploads\/2020\/10\/Screen-Shot-2020-10-21-at-8.58.50-AM.png","pinterest_desc":"Could the GMC Hummer EV be the new favorite truck of RVers? With loads of torque, space, and capability, RVers may turn to Hummer for their next truck."};
/* ]]> */
</script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/mashshare-networks/assets/js/mashnet.min.js?ver=2.5.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashpv = {"postID":"63130","pluginsURL":"https:\/\/rvlife.com\/wp-content\/plugins","ajaxurl":"https:\/\/rvlife.com\/wp-admin\/admin-ajax.php","enableajax":"0","ajaxfreq":"5","realtime":"0","sysload":"1","round":"1","singular":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/mashshare-pageviews/assets/js/mashpv.min.js?ver=1.1.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashbar = {"scroll_distance":"300","mobile_only":"","mobile":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/mashshare-sharebar/assets/js/mashbar.min.js?ver=1.4.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashvipo = {"videoID":"","delay":"500","like_url":"https:\/\/www.facebook.com\/RV-LIFE-Magazine-28544971170","share_text":"Did You Enjoy This Article?<br>Share It With your Friends!","share_button_fb":"Share on Facebook","share_button_tw":"Share on Twitter","like_popup_text":"View More Great RVing Articles<br>By Liking Our Facebook Page","close_button":"No thanks.  Close this Window.","top_position":"0","popup_width":"320","popup_delay":"500","like_popup":"1","share_popup":"1","featured_image":"1","no_video_popup":"0","no_page_popup":"0","image":"https:\/\/rvlife.com\/wp-content\/uploads\/2020\/10\/Screen-Shot-2020-10-21-at-8.58.50-AM-1024x567.png","twitterbtn":"0","videopopuponly":"0","percentage":"90","customtext":"","cookie_support":"1","html_elem":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/mashshare-videopost/assets/js/mashvipo.min.js?ver=1.4.6'></script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/mashshare-videopost/assets/js/jquery.cookie.min.js?ver=1.4.6'></script>
<script type='text/javascript' src='https://rvlife.com/wp-content/themes/milan/js/main.js?ver=1.1.0'></script>
<script>(function(d){var s=d.createElement("script");s.type="text/javascript";s.src="https://a.omappapi.com/app/js/api.min.js";s.async=true;s.id="omapi-script";d.getElementsByTagName("head")[0].appendChild(s);})(document);</script><script type='text/javascript' src='https://rvlife.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://rvlife.com/wp-includes/js/wp-util.min.js?ver=5.2.7'></script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/search-by-algolia-instant-relevant-results/includes/../js/algoliasearch/algoliasearch.jquery.min.js?ver=2.11.3'></script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/search-by-algolia-instant-relevant-results/includes/../js/autocomplete.js/autocomplete.min.js?ver=2.11.3'></script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/search-by-algolia-instant-relevant-results/includes/../js/autocomplete-noconflict.js?ver=2.11.3'></script>
<link rel='https://api.w.org/' href='https://rvlife.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://rvlife.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://rvlife.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.7" />
<link rel='shortlink' href='https://wp.me/p5OLKW-gqe' />
<link rel="alternate" type="application/json+oembed" href="https://rvlife.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frvlife.com%2Fhummer-ev%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://rvlife.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frvlife.com%2Fhummer-ev%2F&#038;format=xml" />
<style type="text/css"> .enews .screenread {
	height: 1px;
    left: -1000em;
    overflow: hidden;
    position: absolute;
    top: -1000em;
    width: 1px; } </style><meta name="google-site-verification" content="NEjacJGfgsYPOrD6GDzdLk4VGJ1T_NeXZFiPpEvf0-A" />
<!-- Google Tag Manager for WordPress by gtm4wp.com -->
<script data-cfasync="false" data-pagespeed-no-defer type="text/javascript">//<![CDATA[
	var dataLayer_content = {"pagePostType":"post","pagePostType2":"single-post","pageCategory":["product-news","product-spotlight","rv-news"],"pageAttributes":["evs","gmc","gmc-hummer-ev","hummer","towing","trucks"],"pagePostAuthor":"Patrick Buchanan"};
	dataLayer.push( dataLayer_content );//]]>
</script>
<script data-cfasync="false">//<![CDATA[
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.'+'js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N72CMXC');//]]>
</script>
<!-- End Google Tag Manager -->
<!-- End Google Tag Manager for WordPress by gtm4wp.com --><style type='text/css'>img#wpstats{display:none}</style><link rel="pingback" href="https://rvlife.com/xmlrpc.php" />
<meta http-equiv="Content-Security-Policy" content="block-all-mixed-content" />

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1519420411625399');
fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1519420411625399&ev=PageView&noscript=1"
/></noscript>
<!-- DO NOT MODIFY -->
<!-- End Facebook Pixel Code -->

<meta property="fb:pages" content="28544971170" />

<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '863082490488838',
      xfbml      : true,
      version    : 'v2.7'
    });
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>

<meta name="robots" content="max-image-preview:large"><script type="text/javascript">var algolia = {"debug":false,"application_id":"H0LPZK92QJ","search_api_key":"caf5f8f0310a905c9919a1535c2b8c77","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"wp_rvlife_searchable_posts","label":"All posts","admin_name":"All posts","position":1,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"wp_rvlife_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]}}};</script>	<style type="text/css">
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	<link rel="amphtml" href="https://rvlife.com/hummer-ev/amp/"><link rel="icon" href="https://rvlife.com/wp-content/uploads/2019/09/cropped-App-Icon-32x32.png" sizes="32x32" />
<link rel="icon" href="https://rvlife.com/wp-content/uploads/2019/09/cropped-App-Icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://rvlife.com/wp-content/uploads/2019/09/cropped-App-Icon-180x180.png" />
<meta name="msapplication-TileImage" content="https://rvlife.com/wp-content/uploads/2019/09/cropped-App-Icon-270x270.png" />
			<link rel="stylesheet" type="text/css" id="wp-custom-css" href="https://rvlife.com/?custom-css=0ff5867201" />
		<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script type="text/html" id="tmpl-autocomplete-header">
  <div class="autocomplete-header">
	<div class="autocomplete-header-title">{{{ data.label }}}</div>
	<div class="clear"></div>
  </div>
</script>

<script type="text/html" id="tmpl-autocomplete-post-suggestion">
  <a class="suggestion-link" href="{{ data.permalink }}" title="{{ data.post_title }}">
	<# if ( data.images.thumbnail ) { #>
	  <img class="suggestion-post-thumbnail" src="{{ data.images.thumbnail.url }}" alt="{{ data.post_title }}">
	  <# } #>
		<div class="suggestion-post-attributes">
		  <span class="suggestion-post-title">{{{ data._highlightResult.post_title.value }}}</span>
		  <# if ( data._snippetResult['content'] ) { #>
			<span class="suggestion-post-content">{{{ data._snippetResult['content'].value }}}</span>
			<# } #>
		</div>
  </a>
</script>

<script type="text/html" id="tmpl-autocomplete-term-suggestion">
  <a class="suggestion-link" href="{{ data.permalink }}" title="{{ data.name }}">
	<svg viewBox="0 0 21 21" width="21" height="21">
	  <svg width="21" height="21" viewBox="0 0 21 21">
		<path
			d="M4.662 8.72l-1.23 1.23c-.682.682-.68 1.792.004 2.477l5.135 5.135c.7.693 1.8.688 2.48.005l1.23-1.23 5.35-5.346c.31-.31.54-.92.51-1.36l-.32-4.29c-.09-1.09-1.05-2.06-2.15-2.14l-4.3-.33c-.43-.03-1.05.2-1.36.51l-.79.8-2.27 2.28-2.28 2.27zm9.826-.98c.69 0 1.25-.56 1.25-1.25s-.56-1.25-1.25-1.25-1.25.56-1.25 1.25.56 1.25 1.25 1.25z"
			fill-rule="evenodd"></path>
	  </svg>
	</svg>
	<span class="suggestion-post-title">{{{ data._highlightResult.name.value }}}</span>
  </a>
</script>

<script type="text/html" id="tmpl-autocomplete-user-suggestion">
  <a class="suggestion-link user-suggestion-link" href="https://rvlife.com/author/the-full-timing-nomad/" title="Rene Agredano - The Full Timing Nomad">
	<# if ( data.avatar_url ) { #>
	  <img class="suggestion-user-thumbnail" src="{{ data.avatar_url }}" alt="{{ data.display_name }}">
	  <# } #>

		<span class="suggestion-post-title">{{{ data._highlightResult.display_name.value }}}</span>
  </a>
</script>

<script type="text/html" id="tmpl-autocomplete-footer">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</script>

<script type="text/html" id="tmpl-autocomplete-empty">
  <div class="autocomplete-empty">
	  No results matched your query 	<span class="empty-query">"{{ data.query }}"</span>
  </div>
</script>

<script type="text/javascript">
  jQuery(function () {
	/* init Algolia client */
	var client = algoliasearch(algolia.application_id, algolia.search_api_key);

	/* setup default sources */
	var sources = [];
	jQuery.each(algolia.autocomplete.sources, function (i, config) {
	  var suggestion_template = wp.template(config['tmpl_suggestion']);
	  sources.push({
		source: algoliaAutocomplete.sources.hits(client.initIndex(config['index_name']), {
		  hitsPerPage: config['max_suggestions'],
		  attributesToSnippet: [
			'content:10'
		  ],
		  highlightPreTag: '__ais-highlight__',
		  highlightPostTag: '__/ais-highlight__'
		}),
		templates: {
		  header: function () {
			return wp.template('autocomplete-header')({
			  label: _.escape(config['label'])
			});
		  },
		  suggestion: function (hit) {
      if(hit.escaped === true) {
        return suggestion_template(hit);
      }
      hit.escaped = true;

			for (var key in hit._highlightResult) {
			  /* We do not deal with arrays. */
			  if (typeof hit._highlightResult[key].value !== 'string') {
				continue;
			  }
			  hit._highlightResult[key].value = _.escape(hit._highlightResult[key].value);
			  hit._highlightResult[key].value = hit._highlightResult[key].value.replace(/__ais-highlight__/g, '<em>').replace(/__\/ais-highlight__/g, '</em>');
			}

			for (var key in hit._snippetResult) {
			  /* We do not deal with arrays. */
			  if (typeof hit._snippetResult[key].value !== 'string') {
				continue;
			  }

			  hit._snippetResult[key].value = _.escape(hit._snippetResult[key].value);
			  hit._snippetResult[key].value = hit._snippetResult[key].value.replace(/__ais-highlight__/g, '<em>').replace(/__\/ais-highlight__/g, '</em>');
			}

			return suggestion_template(hit);
		  }
		}
	  });

	});

	/* Setup dropdown menus */
	jQuery(algolia.autocomplete.input_selector).each(function (i) {
	  var $searchInput = jQuery(this);

	  var config = {
		debug: algolia.debug,
		hint: false,
		openOnFocus: true,
		appendTo: 'body',
		templates: {
		  empty: wp.template('autocomplete-empty')
		}
	  };

	  if (algolia.powered_by_enabled) {
		config.templates.footer = wp.template('autocomplete-footer');
	  }

	  /* Instantiate autocomplete.js */
	  var autocomplete = algoliaAutocomplete($searchInput[0], config, sources)
	  .on('autocomplete:selected', function (e, suggestion) {
		/* Redirect the user when we detect a suggestion selection. */
		window.location.href = suggestion.permalink;
	  });

	  /* Force the dropdown to be re-drawn on scroll to handle fixed containers. */
	  jQuery(window).scroll(function() {
		if(autocomplete.autocomplete.getWrapper().style.display === "block") {
		  autocomplete.autocomplete.close();
		  autocomplete.autocomplete.open();
		}
	  });
	});

	jQuery(document).on("click", ".algolia-powered-by-link", function (e) {
	  e.preventDefault();
	  window.location = "https://www.algolia.com/?utm_source=WordPress&utm_medium=extension&utm_content=" + window.location.hostname + "&utm_campaign=poweredby";
	});
  });
</script>
</head>
<body class="post-template-default single single-post postid-63130 single-format-standard wp-custom-logo custom-header header-image header-full-width content-sidebar genesis-breadcrumbs-visible magazine-pro-blue">
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-N72CMXC"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<!-- Google Tag Manager (noscript) -->
<!-- Google Tag Manager (noscript) --><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li><li><a href="#genesis-footer-widgets" class="screen-reader-shortcut"> Skip to footer</a></li></ul><header class="site-header"><a href="/" style="display:inline-block;padding:15px"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="/wp-content/themes/milan/images/logo.png" /><noscript><img src="/wp-content/themes/milan/images/logo.png" /></noscript></a><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://rvlife.com/">RV LIFE</a></p><p class="site-description">Tools That Make Camping Simple</p></div>	<button id="menu-toggle" class="menu-toggle" aria-controls="primary-menu" aria-expanded="false"><span class="screen-reader-text">Primary Navigation Menu</span></button>
</div></header>	<div id="slide-menu" class="slide-menu">
		<a href="https://rvlife.com/" class="custom-logo-link" rel="home"><img width="512" height="512" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20512%20512'%3E%3C/svg%3E" class="custom-logo" alt="RV LIFE" data-lazy-srcset="https://rvlife.com/wp-content/uploads/2019/09/App-Icon.png 512w, https://rvlife.com/wp-content/uploads/2019/09/App-Icon-350x350.png 350w, https://rvlife.com/wp-content/uploads/2019/09/App-Icon-150x150.png 150w, https://rvlife.com/wp-content/uploads/2019/09/App-Icon-300x300.png 300w, https://rvlife.com/wp-content/uploads/2019/09/App-Icon-100x100.png 100w" data-lazy-sizes="(max-width: 512px) 100vw, 512px" data-attachment-id="54676" data-permalink="https://rvlife.com/app-icon/" data-orig-file="https://rvlife.com/wp-content/uploads/2019/09/App-Icon.png" data-orig-size="512,512" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="App-Icon" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2019/09/App-Icon-300x300.png" data-large-file="https://rvlife.com/wp-content/uploads/2019/09/App-Icon.png" data-lazy-src="https://rvlife.com/wp-content/uploads/2019/09/App-Icon.png" /><noscript><img width="512" height="512" src="https://rvlife.com/wp-content/uploads/2019/09/App-Icon.png" class="custom-logo" alt="RV LIFE" srcset="https://rvlife.com/wp-content/uploads/2019/09/App-Icon.png 512w, https://rvlife.com/wp-content/uploads/2019/09/App-Icon-350x350.png 350w, https://rvlife.com/wp-content/uploads/2019/09/App-Icon-150x150.png 150w, https://rvlife.com/wp-content/uploads/2019/09/App-Icon-300x300.png 300w, https://rvlife.com/wp-content/uploads/2019/09/App-Icon-100x100.png 100w" sizes="(max-width: 512px) 100vw, 512px" data-attachment-id="54676" data-permalink="https://rvlife.com/app-icon/" data-orig-file="https://rvlife.com/wp-content/uploads/2019/09/App-Icon.png" data-orig-size="512,512" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="App-Icon" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2019/09/App-Icon-300x300.png" data-large-file="https://rvlife.com/wp-content/uploads/2019/09/App-Icon.png" /></noscript></a>		<nav id="site-navigation" class="main-navigation" role="navigation">
			<div class="menu-top-navigation-container"><ul id="primary-menu" class="menu"><li id="menu-item-16279" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16279"><a href="/">Home</a></li>
<li id="menu-item-59910" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-59910"><a href="https://rvlife.com/magazine/">RV LIFE Magazine</a></li>
<li id="menu-item-16286" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16286"><a href="https://rvlife.com/category/top-stories/">Top Stories</a></li>
<li id="menu-item-17817" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-17817"><a href="https://rvlife.com/rv-life-columns/">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-33370" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33370"><a href="https://rvlife.com/category/columns/on-the-road-for-good/">On the Road</a></li>
	<li id="menu-item-17827" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17827"><a href="https://rvlife.com/category/columns/tech-tips/">Tech Tips</a></li>
	<li id="menu-item-17825" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17825"><a href="https://rvlife.com/category/columns/rv-golfer/">RV Golfer</a></li>
	<li id="menu-item-17822" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17822"><a href="https://rvlife.com/category/columns/fishin/">Fishin&#8217;</a></li>
	<li id="menu-item-18399" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18399"><a href="https://rvlife.com/category/columns/blogs-at-rvlifecom/">Blogs At RVLife.com</a></li>
	<li id="menu-item-17830" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17830"><a href="https://rvlife.com/category/columns/publishers-corner/">Publisher&#8217;s Corner</a></li>
</ul>
</li>
<li id="menu-item-17819" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-17819"><a href="https://rvlife.com/departments/">Departments</a>
<ul class="sub-menu">
	<li id="menu-item-16308" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16308"><a href="https://rvlife.com/category/departments/rv-industry-news/">RV Industry News</a></li>
	<li id="menu-item-16309" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16309"><a href="https://rvlife.com/category/departments/product-news/">Product News</a></li>
	<li id="menu-item-16307" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16307"><a href="https://rvlife.com/category/departments/campground-spotlight/">Campground Spotlight</a></li>
	<li id="menu-item-16310" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16310"><a href="https://rvlife.com/category/departments/product-spotlight/">Product Spotlight</a></li>
	<li id="menu-item-21297" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21297"><a href="https://rvlife.com/events/">Calendar of Events</a></li>
	<li id="menu-item-17829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17829"><a href="https://rvlife.com/category/departments/rv-books/">RV Books</a></li>
</ul>
</li>
<li id="menu-item-18501" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-18501"><a href="https://rvlife.com/rv-blogs/">Blogs</a>
<ul class="sub-menu">
	<li id="menu-item-16524" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16524"><a href="https://rvlife.com/author/the-full-timing-nomad/">The Full Timing Nomad</a></li>
	<li id="menu-item-16613" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16613"><a href="https://rvlife.com/author/adventures-in-rving/">Adventures in RVing</a></li>
	<li id="menu-item-16616" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16616"><a href="https://rvlife.com/author/rv-travel-tales/">RV Travel Tales</a></li>
	<li id="menu-item-16615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16615"><a href="https://rvlife.com/author/the-silver-gypsy/">The Silver Gypsy</a></li>
	<li id="menu-item-16655" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16655"><a href="https://rvlife.com/author/the-healthy-traveler/">The Healthy Traveler</a></li>
	<li id="menu-item-16614" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16614"><a href="https://rvlife.com/author/great-escapes/">Great Escapes</a></li>
	<li id="menu-item-16612" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16612"><a href="https://rvlife.com/author/the-19th-hole/">The 19th Hole</a></li>
</ul>
</li>
<li id="menu-item-53443" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53443"><a target="_blank" rel="noopener noreferrer" href="http://www.rvlife.com/app">App</a></li>
</ul></div>		</nav><!-- #site-navigation -->
	</div><!-- #slide-menu -->
<div class="site-inner">
<script>
setTimeout(
  function()
  {
    jQuery('#ds_cpp_inner').append('<a href="#" onclick="disableVid();" class="trending-optout" style="position:relative;display:block;margin-bottom:-20px;text-align:right;font-size:10px;">&times; Please don\'t show me this widget (disabled on future page views).</a>');
  }, 4000);

    function disableVid() {
      document.cookie = "no_widget_content=1";
    };
</script>
<div class="content-sidebar-wrap"><main class="content" id="genesis-content"><div class="breadcrumb">You are here: <span class="breadcrumb-link-wrap"><a class="breadcrumb-link" href="https://rvlife.com/"><span class="breadcrumb-link-text-wrap">Home</span></a><meta ></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap"><a class="breadcrumb-link" href="https://rvlife.com/category/departments/"><span class="breadcrumb-link-text-wrap">Departments</span></a><meta ></span> <span aria-label="breadcrumb separator">/</span> <span class="breadcrumb-link-wrap"><a class="breadcrumb-link" href="https://rvlife.com/category/departments/product-spotlight/"><span class="breadcrumb-link-text-wrap">Product Spotlight</span></a><meta ></span> <span aria-label="breadcrumb separator">/</span> Will The Hummer EV Be The New Favorite For RVers?</div><article class="post-63130 post type-post status-publish format-standard has-post-thumbnail category-product-news category-product-spotlight category-rv-news tag-evs tag-gmc tag-gmc-hummer-ev tag-hummer tag-towing tag-trucks entry"><header class="entry-header"><h1 class="entry-title">Will The Hummer EV Be The New Favorite For RVers?</h1>
<p class="entry-meta"></p></header><div class="entry-wrap"><div class="entry-meta"><div class="post-author"><img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2070%2070'%3E%3C/svg%3E" data-lazy-srcset='https://rvlife.com/wp-content/uploads/2020/04/crpic.png 2x' class='avatar avatar-70 photo sab-custom-avatar' height='70' width='70' data-lazy-src="https://rvlife.com/wp-content/uploads/2020/04/crpic.png" /><noscript><img alt='' src='https://rvlife.com/wp-content/uploads/2020/04/crpic.png' srcset='https://rvlife.com/wp-content/uploads/2020/04/crpic.png 2x' class='avatar avatar-70 photo sab-custom-avatar' height='70' width='70' /></noscript><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://rvlife.com/author/patrickbuchanan/">Patrick Buchanan</a></span></span></div><span class="posted-on"><a href="https://rvlife.com/hummer-ev/" rel="bookmark"><time class="entry-date published" datetime="2020-10-21T16:55:38-05:00">October 21, 2020</time><time class="updated" datetime="2020-10-21T18:52:41-05:00">October 21, 2020</time></a></span><span class="cat-links"><span class="cats-title">Filed under:</span><ul class="post-categories">
	<li><a href="https://rvlife.com/category/departments/product-news/" rel="category tag">Product News</a></li>
	<li><a href="https://rvlife.com/category/departments/product-spotlight/" rel="category tag">Product Spotlight</a></li>
	<li><a href="https://rvlife.com/category/rv-news/" rel="category tag">RV News</a></li></ul></span></div><div class="entry-content"><p><img data-attachment-id="63131" data-permalink="https://rvlife.com/hummer-ev/screen-shot-2020-10-21-at-6-36-35-am/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM.png" data-orig-size="2460,1342" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screen Shot 2020-10-21 at 6.36.35 AM" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM-300x164.png" data-large-file="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM-1024x559.png" class="aligncenter wp-image-63131 size-large" title="GMC Hummer EV" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20559'%3E%3C/svg%3E" alt="GMC Hummer EV" width="1024" height="559" data-lazy-srcset="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM-1024x559.png 1024w, https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM-300x164.png 300w, https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM-768x419.png 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM-1024x559.png" /><noscript><img data-attachment-id="63131" data-permalink="https://rvlife.com/hummer-ev/screen-shot-2020-10-21-at-6-36-35-am/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM.png" data-orig-size="2460,1342" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screen Shot 2020-10-21 at 6.36.35 AM" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM-300x164.png" data-large-file="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM-1024x559.png" class="aligncenter wp-image-63131 size-large" title="GMC Hummer EV" src="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM-1024x559.png" alt="GMC Hummer EV" width="1024" height="559" srcset="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM-1024x559.png 1024w, https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM-300x164.png 300w, https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-6.36.35-AM-768x419.png 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript></p>
<h2><span style="font-weight: 400;">Will The Hummer EV Be The New Favorite For RVers?</span></h2>
<p><span style="font-weight: 400;">RVers love their trucks, and why shouldn’t they? Those <a href="https://camperreport.com/best-2021-trucks-for-towing/">trucks tow the RVs</a> those same truck lovers own. A capable truck is often what makes the difference between an enjoyable RV journey and a white-knuckle ride. RVers know that it’s vital to choose your truck and RV combination wisely. </span></p>
<p><span style="font-weight: 400;">Electric trucks are already poised to encroach on territory dominated by the Ford F-Series trucks. Tesla’s Cybertruck piqued the interest of RVers with its stout torque and towing capabilities. Now, GMC has done the same with its new truck, the Hummer EV. By resurrecting an old name with a newer shape and cutting edge technology, will the Hummer EV be the new favorite truck for RVers?</span></p>
<h2><span style="font-weight: 400;">The GMC Hummer EV Torque</span></h2>
<p><span style="font-weight: 400;">GMC’s new EV appears to be taking a page from several books. Building on the electric success of Tesla, the <a href="https://www.dpbolvw.net/click-100173535-12803976" target="_blank" rel="noopener noreferrer">Jeep Wrangler’s</a> open-air accessibility, and the <a href="https://camperreport.com/ford-bronco/" target="_blank" rel="noopener noreferrer">Ford Bronco’s</a> retro-revival style, the new Hummer appears to be hitting on all…electric motors. </span></p>
<p><span style="font-weight: 400;">Will the Hummer EV be a solid truck for RVers though? GMC currently estimates that their new EV will achieve up to 1,000 horsepower and 11,500 lb-ft of torque. Those are ridiculous numbers, and as of yet are still </span><i><span style="font-weight: 400;">estimated</span></i><span style="font-weight: 400;">. To put that torque number into perspective, here are a few examples that RVers can relate to:</span></p>
<ul>
<li style="font-weight: 400; text-align: left;"><span style="font-weight: 400;">1,850 lb-ft &#8211; Volvo D13 diesel engine found in 45 ft. Prevost luxury coaches.</span></li>
<li style="font-weight: 400; text-align: left;"><span style="font-weight: 400;">1,150 lb-ft &#8211; 2021 Tiffin Phaeton 40 IH Class A motorhome</span></li>
<li style="font-weight: 400; text-align: left;"><span style="font-weight: 400;">1,050 lb-ft &#8211; 2021 Ford F250/F350/F450 diesel truck</span></li>
<li style="font-weight: 400; text-align: left;"><span style="font-weight: 400;">442 lb-ft &#8211; 2021 Jeep Wrangler diesel</span></li>
</ul>
<p>&nbsp;</p>
<p><span style="font-weight: 400;">For RVers looking to pull a travel trailer or 5th wheel, torque is more important than horsepower. </span><a href="https://www.trucksonlysales.com/blog/what-is-more-important-horsepower-or-torque" target="_blank" rel="noopener noreferrer"><span style="font-weight: 400;">Trucks Only states it well here</span></a><span style="font-weight: 400;">;</span></p>
<blockquote><p><i><span style="font-weight: 400;">“Torque is all about generating low-end power. It’s good for getting your vehicle in motion and on the move. Torque is good for trucks that need to pull a lot of weight around. In simple terms, you can think of torque as a measure of how much work your vehicle can do.&nbsp; A healthy amount of torque is what pulls you up hills and helps you haul trailers around.”</span></i></p></blockquote>
<h2><span style="font-weight: 400;">Hummer EV Specs</span></h2>
<p><span style="font-weight: 400;">Here are some of the estimated Hummer EV specs as released by GMC.&nbsp;</span></p>
<ul>
<li style="font-weight: 400; text-align: left;"><span style="font-weight: 400;">Horsepower &#8211; 1,000</span></li>
<li style="font-weight: 400; text-align: left;"><span style="font-weight: 400;">Torque &#8211; 11,500 lb-ft</span></li>
<li style="font-weight: 400; text-align: left;"><span style="font-weight: 400;">Driving Range on a full charge &#8211; 350 miles</span></li>
<li style="font-weight: 400; text-align: left;"><span style="font-weight: 400;">0 &#8211; 60 mph &#8211; 3 seconds</span></li>
<li style="font-weight: 400; text-align: left;"><span style="font-weight: 400;">Ground Clearance &#8211; 11.9 inches (15.9 w/extract mode)</span></li>
<li style="font-weight: 400; text-align: left;"><span style="font-weight: 400;">Water Fording &#8211; 28 inches (32” w/extract mode)</span></li>
</ul>
<h2><span style="font-weight: 400;">Can I charge the Hummer EV at a campground?</span></h2>
<p><span style="font-weight: 400;">The new GMC Hummer will use a 30-amp cord to charge. It is expected that like the Tesla, there will be adapters available to take the Hummer cord to a standard TT-30 campground pedestal receptacle. </span></p>
<p><span style="font-weight: 400;">One would also expect a J1772 adapter to be in the mix in some way, either included with the Hummer or as a separate purchase to charge your new EV at standard charging stations. GMC is offering some trim levels of the Hummer to include an 800 VDC fast charger to allow nearly 100 miles of range in just a 10-minute charge.</span></p>
<p><iframe src="https://www.youtube.com/embed/evE1IUiVOI0" width="1000" height="560" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<h2><span style="font-weight: 400;">Can I flat tow a Hummer EV?</span></h2>
<p><span style="font-weight: 400;">Very little detail is given at this time about <a href="https://rvlife.com/rv-towing/" target="_blank" rel="noopener noreferrer">flat towing</a> the Hummer EV. We can however see the integrated tow hooks adorning both the front and rear bumpers. This leads us to believe that flat towing is a possibility. </span></p>
<p><span style="font-weight: 400;">Weight was not provided at this time, however, based on Rivian and Cybertruck weights, you can expect this new truck to weigh in at well over the 5,000 lb. towing limit set by smaller motorhomes. If you see one of these being towed behind a motorhome, it will likely be a larger one with a 10,000 lb or more towing capacity.</span></p>
<h2><span style="font-weight: 400;">Hummer EV Crabwalk and other special features</span></h2>
<p><span style="font-weight: 400;">Introduced with the new Hummer is a slew of interesting features. The Crabwalk certainly brings the wow-factor. Designed to help you get out of an <a href="https://rvlife.com/earthroamer-vehicles/" target="_blank" rel="noopener noreferrer">off-road</a> jam, Crabwalk utilizes the Hummer’s 4-wheel steering to allow driving diagonally, up to 10-degrees in either direction, to help with egress.</span></p>
<p><span style="font-weight: 400;">The new Hummer’s Extract Mode is another feature designed to help with off-roading. Extract mode utilizes an air suspension to raise the Hummer EV an additional 6 inches to clear obstacles and provide additional water fording.</span></p>
<p><span style="font-weight: 400;">Like the <a href="https://camperreport.com/jeep-wrangler/" target="_blank" rel="noopener noreferrer">Jeep Wrangler, ever-popular with RVers</a>, the new Hummer affords the ability to “go topless” by using modular sky panels as part of its Infinity Roof. Removing those panels reveals a luxurious interior and a very Tesla-like, large control screen. </span></p>
<p><span style="font-weight: 400;">Space isn’t a problem of course. With no internal combustion engine and transmission to get in the way, the interior appears quite spacious.</span></p>
<div id="attachment_63132" style="width: 1034px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-63132" data-attachment-id="63132" data-permalink="https://rvlife.com/hummer-ev/screen-shot-2020-10-21-at-7-34-19-am/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM.png" data-orig-size="2010,1136" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screen Shot 2020-10-21 at 7.34.19 AM" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM-300x170.png" data-large-file="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM-1024x579.png" class="wp-image-63132 size-large" title="Hummer EV Interior" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20579'%3E%3C/svg%3E" alt="Hummer EV Interior" width="1024" height="579" data-lazy-srcset="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM-1024x579.png 1024w, https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM-300x170.png 300w, https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM-768x434.png 768w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM-1024x579.png" /><noscript><img aria-describedby="caption-attachment-63132" data-attachment-id="63132" data-permalink="https://rvlife.com/hummer-ev/screen-shot-2020-10-21-at-7-34-19-am/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM.png" data-orig-size="2010,1136" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Screen Shot 2020-10-21 at 7.34.19 AM" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM-300x170.png" data-large-file="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM-1024x579.png" class="wp-image-63132 size-large" title="Hummer EV Interior" src="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM-1024x579.png" alt="Hummer EV Interior" width="1024" height="579" srcset="https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM-1024x579.png 1024w, https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM-300x170.png 300w, https://rvlife.com/wp-content/uploads/2020/10/Screen-Shot-2020-10-21-at-7.34.19-AM-768x434.png 768w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript><p id="caption-attachment-63132" class="wp-caption-text"><em>The interior of the new Hummer EV is spacious</em></p></div>
<h2><span style="font-weight: 400;">Hummer EV price and availability</span></h2>
<p><span style="font-weight: 400;">If you aren’t in a hurry, the new GMC Hummer EV2 will start at $79,995. This “low-end” version isn’t expected to be available until 2024 however. The initial launch will be with the Edition 1, starting at $112,595, slated to arrive in the fall of 2021. The EV3X at $99,995 and EV2X at $89,995 will follow in subsequent years, culminating with the EV2. These four models will round out the full line.&nbsp;</span></p>
<p><span style="font-weight: 400;">Time will tell how many will pony up the cash for these electric ponies. With that said, at the time of this writing, GMC’s official website noted that reservations were already full for the Edition 1. </span></p>
<p><span style="font-weight: 400;">The bigger picture is likely that this truck will continue to accelerate the EV era for all vehicles. If aftermarket manufacturers can expound on available accessories and options, the Hummer EV might be the perfect truck for RVers.</span></p>
<a href="https://www.rvlife.com/?utm_source=rvlifenetwork&utm_medium=article&utm_campaign=articleend" class="rvlife-pro-bttm" style="display:block;margin-bottom:21px;font-size:20px;" target="_blank">Research Campgrounds, Plan RV Safe Routes &amp; Turn your phone into an RV GPS. <br>Try the RV LIFE Pro Bundle FREE for 7 days</a><div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-gravatar"><a  href='https://rvlife.com/author/patrickbuchanan/'><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="" itemprop="image" data-lazy-src="https://rvlife.com/wp-content/uploads/2020/04/crpic.png"><noscript><img src="https://rvlife.com/wp-content/uploads/2020/04/crpic.png" alt="" itemprop="image"></noscript></a></div><div class="saboxplugin-authorname"><a href="https://rvlife.com/author/patrickbuchanan/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Patrick Buchanan</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p>All around RV enthusiast who enjoys trips with his wife and little dogs in their 43-foot diesel pusher.</p>
</div></div><div class="clearfix"></div></div><aside class="mashsb-container mashsb-main mashsb-stretched"><div class="mashsb-box"><div class="mashsb-count mash-large" style="float:left;"><div class="counts mashsbcount">25</div><span class="mashsb-sharetext">SHARES</span></div><div class="mashsb-buttons"><div class="mashpv mashsb-count mash-large" data-mashpv-postid="63130" data-mashtip="This number shows the total pageviews since publishing of the article"><div class="count">4.7k</div><span class="mashsb-sharetext">VIEWS</span></div><a class="mashicon-facebook mash-large mash-center mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Frvlife.com%2Fhummer-ev%2F" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Share</span></a><a class="mashicon-twitter mash-large mash-center mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Will%20The%20Hummer%20EV%20Be%20The%20New%20Favorite%20For%20RVers%3F&url=https://rvlife.com/hummer-ev/&via=rvlifemagazine" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Tweet</span></a><div class="onoffswitch mash-large mashsb-noshadow"></div><div class="secondary-shares" style="display:none;"><a class="mashicon-pinterest mash-large mash-center mashsb-noshadow" href="#" data-mashsb-url="https://pinterest.com/pin/create/button/?url=https%3A%2F%2Frvlife.com%2Fhummer-ev%2F&amp;media=https%3A%2F%2Frvlife.com%2Fwp-content%2Fuploads%2F2020%2F10%2FScreen-Shot-2020-10-21-at-8.58.50-AM.png&amp;description=Could+the+GMC+Hummer+EV+be+the+new+favorite+truck+of+RVers%3F+With+loads+of+torque%2C+space%2C+and+capability%2C+RVers+may+turn+to+Hummer+for+their+next+truck." target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Pinterest</span></a><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div></div>
            </div>
                <div style="clear:both;"></div><div class="mashsb-toggle-container"></div></aside>
            <!-- Share buttons by mashshare.net - Version: 3.7.6--><!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="https://rvlife.com/hummer-ev/"
    dc:identifier="https://rvlife.com/hummer-ev/"
    dc:title="Will The Hummer EV Be The New Favorite For RVers?"
    trackback:ping="https://rvlife.com/hummer-ev/trackback/" />
</rdf:RDF>-->
</div></div><!-- .entry-wrap --><footer class="entry-footer"><span class="tags-links"><span class="tags-title">Tagged: </span><ul><li><a href="https://rvlife.com/tag/evs/" rel="tag">EVs</a></li><li><a href="https://rvlife.com/tag/gmc/" rel="tag">GMC</a></li><li><a href="https://rvlife.com/tag/gmc-hummer-ev/" rel="tag">GMC Hummer EV</a></li><li><a href="https://rvlife.com/tag/hummer/" rel="tag">hummer</a></li><li><a href="https://rvlife.com/tag/towing/" rel="tag">towing</a></li><li><a href="https://rvlife.com/tag/trucks/" rel="tag">trucks</a></li></ul></span>	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links">
						<div class="nav-previous">
				<span class="nav-label">Previous Post</span>
			<div><a href="https://rvlife.com/rv-costs-surprising/" rel="prev"><img width="300" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20150'%3E%3C/svg%3E" class="attachment-300x150 size-300x150 wp-post-image" alt="" data-attachment-id="62865" data-permalink="https://rvlife.com/amazon-prime-day-deals-2020/instant-pot-2/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/10/amazonprimeday.jpg" data-orig-size="5184,3888" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Ajay Suresh&quot;,&quot;camera&quot;:&quot;E-M1MarkIII&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1589749367&quot;,&quot;copyright&quot;:&quot;CC BY 2.0&quot;,&quot;focal_length&quot;:&quot;60&quot;,&quot;iso&quot;:&quot;200&quot;,&quot;shutter_speed&quot;:&quot;0.2&quot;,&quot;title&quot;:&quot;Instant Pot&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Instant Pot" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/10/amazonprimeday-300x225.jpg" data-large-file="https://rvlife.com/wp-content/uploads/2020/10/amazonprimeday-1024x768.jpg" data-lazy-src="https://rvlife.com/wp-content/uploads/2020/10/amazonprimeday-700x350.jpg" /><noscript><img width="300" height="150" src="https://rvlife.com/wp-content/uploads/2020/10/amazonprimeday-700x350.jpg" class="attachment-300x150 size-300x150 wp-post-image" alt="" data-attachment-id="62865" data-permalink="https://rvlife.com/amazon-prime-day-deals-2020/instant-pot-2/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/10/amazonprimeday.jpg" data-orig-size="5184,3888" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Ajay Suresh&quot;,&quot;camera&quot;:&quot;E-M1MarkIII&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1589749367&quot;,&quot;copyright&quot;:&quot;CC BY 2.0&quot;,&quot;focal_length&quot;:&quot;60&quot;,&quot;iso&quot;:&quot;200&quot;,&quot;shutter_speed&quot;:&quot;0.2&quot;,&quot;title&quot;:&quot;Instant Pot&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Instant Pot" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/10/amazonprimeday-300x225.jpg" data-large-file="https://rvlife.com/wp-content/uploads/2020/10/amazonprimeday-1024x768.jpg" /></noscript>3 RV Costs That Might Surprise You <span class="meta-nav">&rarr;</span></a></div>			</div>

											<div class="nav-next">
					<span class="nav-label">Next Post</span>

					<div><a href="https://rvlife.com/class-c-rvs/" rel="next">5 Best Class C RVs In 2021 <span class="meta-nav">&rarr;</span></a></div>				</div>
			

		</div><!-- .nav-links -->
	</nav><!-- .navigation -->

	<div>



	<div class="news-opt">
		<a href="https://app.monstercampaigns.com/c/s11mtry8rb0powbk298e/" target="_blank">Get Free Weekly RV LIFE Updates in your Email Inbox</a>
	</div>



	</div>
</article><h2 class="screen-reader-text">Reader Interactions</h2><div class="entry-comments" id="comments"><div class="comments-header"><h3 class="comments-title">Comments</h3></div><ol class="comment-list">
	<li class="comment even thread-even depth-1" id="comment-730588">
	<article >

		
		<header class="comment-header">
			<p class="comment-author">
				<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2048%2048'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/2f660a9beecedcea7c5076d770e0fa1f?s=96&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' data-lazy-src="https://secure.gravatar.com/avatar/2f660a9beecedcea7c5076d770e0fa1f?s=48&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/2f660a9beecedcea7c5076d770e0fa1f?s=48&#038;r=g' srcset='https://secure.gravatar.com/avatar/2f660a9beecedcea7c5076d770e0fa1f?s=96&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /></noscript><span class="comment-author-name">AMW</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://rvlife.com/hummer-ev/#comment-730588">October 21, 2020 at 8:04 pm</a></time></p>		</header>

		<div class="comment-content">
			
			<p>What a miserable trip; having to stop every 100 miles to re-charge.<br />
With a price as high as it is suggested, it should run for a couple of years in a charge.</p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-730588' data-commentid="730588" data-postid="63130" data-belowelement="comment-730588" data-respondelement="respond" aria-label='Reply to AMW'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-730612">
	<article >

		
		<header class="comment-header">
			<p class="comment-author">
				<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2048%2048'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/86b942d807e182b1fdd4d9d188f753be?s=96&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' data-lazy-src="https://secure.gravatar.com/avatar/86b942d807e182b1fdd4d9d188f753be?s=48&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/86b942d807e182b1fdd4d9d188f753be?s=48&#038;r=g' srcset='https://secure.gravatar.com/avatar/86b942d807e182b1fdd4d9d188f753be?s=96&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /></noscript><span class="comment-author-name"><a href="http://www.jmmgarza.com" class="comment-author-link" rel="external nofollow">Jesus Garza</a></span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://rvlife.com/hummer-ev/#comment-730612">October 21, 2020 at 10:23 pm</a></time></p>		</header>

		<div class="comment-content">
			
			<p>Quite the pretentious beast. The overpriced 2022 Hummer is definitely only for the well healed. This GMC EV is a fancy shiny object distracting you from the fact it&#8217;s still more than a year away from production, overweight and uses old EV tech. I do like the crab feature though. Great for parking in the city. I&#8217;d rather own the super sturdy, less expensive and significantly more techy Tesla CyberTruck.</p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-730612' data-commentid="730612" data-postid="63130" data-belowelement="comment-730612" data-respondelement="respond" aria-label='Reply to Jesus Garza'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment even thread-even depth-1" id="comment-730668">
	<article >

		
		<header class="comment-header">
			<p class="comment-author">
				<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2048%2048'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/2dc1328ac791b13caf53cd5b3b59860d?s=96&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' data-lazy-src="https://secure.gravatar.com/avatar/2dc1328ac791b13caf53cd5b3b59860d?s=48&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/2dc1328ac791b13caf53cd5b3b59860d?s=48&#038;r=g' srcset='https://secure.gravatar.com/avatar/2dc1328ac791b13caf53cd5b3b59860d?s=96&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /></noscript><span class="comment-author-name"><a href="http://RENO697@GMAIL.COM" class="comment-author-link" rel="external nofollow">John vaughn</a></span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://rvlife.com/hummer-ev/#comment-730668">October 22, 2020 at 4:46 am</a></time></p>		</header>

		<div class="comment-content">
			
			<p>this<br />
 is great .but how much  ? who can buy it  is it  affordable for the middle class or not</p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-730668' data-commentid="730668" data-postid="63130" data-belowelement="comment-730668" data-respondelement="respond" aria-label='Reply to John vaughn'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->

	<li class="comment odd alt thread-odd thread-alt depth-1" id="comment-730688">
	<article >

		
		<header class="comment-header">
			<p class="comment-author">
				<img alt='' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2048%2048'%3E%3C/svg%3E" data-lazy-srcset='https://secure.gravatar.com/avatar/8119867ca8adfaf8be30cd07522ea1c5?s=96&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' data-lazy-src="https://secure.gravatar.com/avatar/8119867ca8adfaf8be30cd07522ea1c5?s=48&#038;r=g" /><noscript><img alt='' src='https://secure.gravatar.com/avatar/8119867ca8adfaf8be30cd07522ea1c5?s=48&#038;r=g' srcset='https://secure.gravatar.com/avatar/8119867ca8adfaf8be30cd07522ea1c5?s=96&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /></noscript><span class="comment-author-name">Randy Way</span> <span class="says">says</span>			</p>

			<p class="comment-meta"><time class="comment-time"><a class="comment-time-link" href="https://rvlife.com/hummer-ev/#comment-730688">October 22, 2020 at 7:16 am</a></time></p>		</header>

		<div class="comment-content">
			
			<p>Really key questions for RVers:</p>
<p>1.  Is their an AC outlet powered by the battery pack?  (e.g. 30A@120v)<br />
2.  For use in a toad configuration, can the regenerative brakes be used like a brake buddy?</p>
		</div>

		<div class="comment-reply"><a rel='nofollow' class='comment-reply-link' href='#comment-730688' data-commentid="730688" data-postid="63130" data-belowelement="comment-730688" data-respondelement="respond" aria-label='Reply to Randy Way'>Reply</a></div>
		
	</article>
	</li><!-- #comment-## -->
</ol></div>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/hummer-ev/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://rvlife.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='63130' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="352a87e7f2" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="21"/></p>			</form>
			</div><!-- #respond -->
	</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-3" class="widget-odd widget-first widget-1 widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://rvlife.com/" role="search"><label class="search-form-label screen-reader-text" for="searchform-1">Search &#x2026;</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search &#x2026;"><input class="search-form-submit" type="submit" value="&#xf002;"><meta content="https://rvlife.com/?s={s}"></form></div></section>
<section id="custom_html-6" class="widget_text widget-even widget-2 widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget">	<div class="news-opt">
		<a href="https://app.monstercampaigns.com/c/s11mtry8rb0powbk298e/" target="_blank" rel="noopener noreferrer">Get the FREE RV LIFE Newsletter</a>
	</div></div></div></section>
<section id="featured-post-10" class="widget-odd widget-last widget-3 widget featured-content featuredpost"><div class="widget-wrap"><h3 class="widgettitle widget-title">Recent Articles</h3>
<article class="post-63075 post type-post status-publish format-standard has-post-thumbnail category-rv-trailers-and-motorhomes tag-class-c tag-class-c-motorhomes tag-class-c-rv tag-coachmen tag-dynamax tag-rv tag-rv-products tag-thor tag-tiffin entry"><a href="https://rvlife.com/class-c-rvs/" class="alignleft" aria-hidden="true" tabindex="-1"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="entry-image attachment-post" alt="" data-lazy-srcset="https://rvlife.com/wp-content/uploads/2020/10/ClassCRVs-150x150.jpg 150w, https://rvlife.com/wp-content/uploads/2020/10/ClassCRVs-350x350.jpg 350w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="63148" data-permalink="https://rvlife.com/class-c-rvs/classcrvs/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/10/ClassCRVs.jpg" data-orig-size="1600,1067" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ClassCRVs" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/10/ClassCRVs-300x200.jpg" data-large-file="https://rvlife.com/wp-content/uploads/2020/10/ClassCRVs-1024x683.jpg" data-lazy-src="https://rvlife.com/wp-content/uploads/2020/10/ClassCRVs-150x150.jpg" /><noscript><img width="150" height="150" src="https://rvlife.com/wp-content/uploads/2020/10/ClassCRVs-150x150.jpg" class="entry-image attachment-post" alt="" srcset="https://rvlife.com/wp-content/uploads/2020/10/ClassCRVs-150x150.jpg 150w, https://rvlife.com/wp-content/uploads/2020/10/ClassCRVs-350x350.jpg 350w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="63148" data-permalink="https://rvlife.com/class-c-rvs/classcrvs/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/10/ClassCRVs.jpg" data-orig-size="1600,1067" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ClassCRVs" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/10/ClassCRVs-300x200.jpg" data-large-file="https://rvlife.com/wp-content/uploads/2020/10/ClassCRVs-1024x683.jpg" /></noscript></a><header class="entry-header"><h4 class="entry-title"><a href="https://rvlife.com/class-c-rvs/">5 Best Class C RVs In 2021</a></h4></header></article><article class="post-63027 post type-post status-publish format-standard has-post-thumbnail category-top-stories tag-costs tag-mainentance tag-rv-maintenance entry"><a href="https://rvlife.com/rv-costs-surprising/" class="alignleft" aria-hidden="true" tabindex="-1"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="entry-image attachment-post" alt="" data-lazy-srcset="https://rvlife.com/wp-content/uploads/2020/10/RVcosts-150x150.jpg 150w, https://rvlife.com/wp-content/uploads/2020/10/RVcosts-350x350.jpg 350w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="63069" data-permalink="https://rvlife.com/rv-costs-surprising/rvcosts/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/10/RVcosts.jpg" data-orig-size="1600,1200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RVcosts" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/10/RVcosts-300x225.jpg" data-large-file="https://rvlife.com/wp-content/uploads/2020/10/RVcosts-1024x768.jpg" data-lazy-src="https://rvlife.com/wp-content/uploads/2020/10/RVcosts-150x150.jpg" /><noscript><img width="150" height="150" src="https://rvlife.com/wp-content/uploads/2020/10/RVcosts-150x150.jpg" class="entry-image attachment-post" alt="" srcset="https://rvlife.com/wp-content/uploads/2020/10/RVcosts-150x150.jpg 150w, https://rvlife.com/wp-content/uploads/2020/10/RVcosts-350x350.jpg 350w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="63069" data-permalink="https://rvlife.com/rv-costs-surprising/rvcosts/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/10/RVcosts.jpg" data-orig-size="1600,1200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="RVcosts" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/10/RVcosts-300x225.jpg" data-large-file="https://rvlife.com/wp-content/uploads/2020/10/RVcosts-1024x768.jpg" /></noscript></a><header class="entry-header"><h4 class="entry-title"><a href="https://rvlife.com/rv-costs-surprising/">3 RV Costs That Might Surprise You</a></h4></header></article><article class="post-61996 post type-post status-publish format-standard has-post-thumbnail category-great-rving-destinations tag-campgrounds tag-destinations tag-montana tag-national-park tag-national-parks tag-parks tag-trip-ideas tag-wyoming tag-yellowstone entry"><a href="https://rvlife.com/yellowstone-camping/" class="alignleft" aria-hidden="true" tabindex="-1"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="entry-image attachment-post" alt="" data-lazy-srcset="https://rvlife.com/wp-content/uploads/2020/09/yellowstone-camping-150x150.jpg 150w, https://rvlife.com/wp-content/uploads/2020/09/yellowstone-camping-350x350.jpg 350w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="63060" data-permalink="https://rvlife.com/yellowstone-camping/yellowstone-camping-2/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/09/yellowstone-camping.jpg" data-orig-size="1920,1419" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon PowerShot G16&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;8.157&quot;,&quot;iso&quot;:&quot;160&quot;,&quot;shutter_speed&quot;:&quot;0.0005&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="yellowstone-camping" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/09/yellowstone-camping-300x222.jpg" data-large-file="https://rvlife.com/wp-content/uploads/2020/09/yellowstone-camping-1024x757.jpg" data-lazy-src="https://rvlife.com/wp-content/uploads/2020/09/yellowstone-camping-150x150.jpg" /><noscript><img width="150" height="150" src="https://rvlife.com/wp-content/uploads/2020/09/yellowstone-camping-150x150.jpg" class="entry-image attachment-post" alt="" srcset="https://rvlife.com/wp-content/uploads/2020/09/yellowstone-camping-150x150.jpg 150w, https://rvlife.com/wp-content/uploads/2020/09/yellowstone-camping-350x350.jpg 350w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="63060" data-permalink="https://rvlife.com/yellowstone-camping/yellowstone-camping-2/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/09/yellowstone-camping.jpg" data-orig-size="1920,1419" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon PowerShot G16&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;8.157&quot;,&quot;iso&quot;:&quot;160&quot;,&quot;shutter_speed&quot;:&quot;0.0005&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="yellowstone-camping" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/09/yellowstone-camping-300x222.jpg" data-large-file="https://rvlife.com/wp-content/uploads/2020/09/yellowstone-camping-1024x757.jpg" /></noscript></a><header class="entry-header"><h4 class="entry-title"><a href="https://rvlife.com/yellowstone-camping/">Yellowstone Camping: Everything You Need To Know</a></h4></header></article><article class="post-62841 post type-post status-publish format-standard has-post-thumbnail category-top-stories tag-fall tag-fall-camping tag-off-season entry"><a href="https://rvlife.com/fall-camping-is-awesome/" class="alignleft" aria-hidden="true" tabindex="-1"><img width="150" height="150" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" class="entry-image attachment-post" alt="" data-lazy-srcset="https://rvlife.com/wp-content/uploads/2020/10/tree-nature-forest-plant-field-leaf-374239-pxhere.com_-150x150.jpg 150w, https://rvlife.com/wp-content/uploads/2020/10/tree-nature-forest-plant-field-leaf-374239-pxhere.com_-350x350.jpg 350w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="63023" data-permalink="https://rvlife.com/fall-camping-is-awesome/tree-nature-forest-plant-field-leaf-374239-pxhere-com/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/10/tree-nature-forest-plant-field-leaf-374239-pxhere.com_.jpg" data-orig-size="3000,2250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;E-M1&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;77&quot;,&quot;iso&quot;:&quot;200&quot;,&quot;shutter_speed&quot;:&quot;0.008&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tree-nature-forest-plant-field-leaf-374239-pxhere.com" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/10/tree-nature-forest-plant-field-leaf-374239-pxhere.com_-300x225.jpg" data-large-file="https://rvlife.com/wp-content/uploads/2020/10/tree-nature-forest-plant-field-leaf-374239-pxhere.com_-1024x768.jpg" data-lazy-src="https://rvlife.com/wp-content/uploads/2020/10/tree-nature-forest-plant-field-leaf-374239-pxhere.com_-150x150.jpg" /><noscript><img width="150" height="150" src="https://rvlife.com/wp-content/uploads/2020/10/tree-nature-forest-plant-field-leaf-374239-pxhere.com_-150x150.jpg" class="entry-image attachment-post" alt="" srcset="https://rvlife.com/wp-content/uploads/2020/10/tree-nature-forest-plant-field-leaf-374239-pxhere.com_-150x150.jpg 150w, https://rvlife.com/wp-content/uploads/2020/10/tree-nature-forest-plant-field-leaf-374239-pxhere.com_-350x350.jpg 350w" sizes="(max-width: 150px) 100vw, 150px" data-attachment-id="63023" data-permalink="https://rvlife.com/fall-camping-is-awesome/tree-nature-forest-plant-field-leaf-374239-pxhere-com/" data-orig-file="https://rvlife.com/wp-content/uploads/2020/10/tree-nature-forest-plant-field-leaf-374239-pxhere.com_.jpg" data-orig-size="3000,2250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;E-M1&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;77&quot;,&quot;iso&quot;:&quot;200&quot;,&quot;shutter_speed&quot;:&quot;0.008&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="tree-nature-forest-plant-field-leaf-374239-pxhere.com" data-image-description="" data-medium-file="https://rvlife.com/wp-content/uploads/2020/10/tree-nature-forest-plant-field-leaf-374239-pxhere.com_-300x225.jpg" data-large-file="https://rvlife.com/wp-content/uploads/2020/10/tree-nature-forest-plant-field-leaf-374239-pxhere.com_-1024x768.jpg" /></noscript></a><header class="entry-header"><h4 class="entry-title"><a href="https://rvlife.com/fall-camping-is-awesome/">5 Reasons You Should Take A Fall Camping Trip</a></h4></header></article></div></section>
</aside></div></div><div class="footer-widgets" id="genesis-footer-widgets"><h2 class="genesis-sidebar-title screen-reader-text">Footer</h2><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="nav_menu-4" class="widget-odd widget-last widget-first widget-1 widget widget_nav_menu"><div class="widget-wrap"><div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-32706" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32706"><a href="https://rvlife.com/contact/">Contact RV Life</a></li>
<li id="menu-item-32702" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32702"><a href="https://rvlife.com/why-rv-life/">About RV Life</a></li>
<li id="menu-item-32707" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32707"><a href="https://rvlife.com/digital-edition/">Digital Print Archives</a></li>
<li id="menu-item-32708" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32708"><a href="https://rvlife.com/archive/">Search Site Archives</a></li>
<li id="menu-item-53444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53444"><a target="_blank" rel="noopener noreferrer" href="http://www.rvlife.com/app">RV LIFE App</a></li>
</ul></div></div></section>
</div><div class="widget-area footer-widgets-2 footer-widget-area"><section id="custom_html-3" class="widget_text widget-odd widget-last widget-first widget-1 widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div class="text-align:center;">
	<a href="#" style="text-align:center;display:block;line-height:0;">
		<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="RV LIFE App images" data-lazy-src="https://rvlife.com/wp-content/uploads/2019/09/rvlife-fan.png"><noscript><img src="https://rvlife.com/wp-content/uploads/2019/09/rvlife-fan.png" alt="RV LIFE App images"></noscript>
		<hr style="margin:0 0 10px 0;">
	</a>
	<p style="color:#ffffff;text-align:center">
		Discover. Plan. Go. Share
	</p>
</div></div></div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="custom_html-4" class="widget_text widget-odd widget-last widget-first widget-1 widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div class="badges my-4 text-center" style="text-align:center;">
	<h5 style="margin:0 0 10px 0;color:#FF2231;text-align:center;">Get the RV LIFE App Today</h5>
	<a class="badge-link" href="https://rvlife.com/ios" style="float:left;width:100%;text-align:center">
		<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" style="width:200px;" alt="" data-lazy-src="https://www.rvlife.com/app/img/app-store-badge.svg"><noscript><img src="https://www.rvlife.com/app/img/app-store-badge.svg" style="width:200px;" alt=""></noscript>
	</a>
	<a class="badge-link" href="https://rvlife.com/android" style="float:left;width:100%;text-align:center;display:block;">		<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" style="width:200px;text-align:center" alt="Download on Google Play store" data-lazy-src="https://www.rvlife.com/app/img/google-play-badge.svg"><noscript><img src="https://www.rvlife.com/app/img/google-play-badge.svg" style="width:200px;text-align:center" alt="Download on Google Play store"></noscript>
	</a>
</div></div></div></section>
</div></div></div><footer class="site-footer"><div class="wrap"><p>Copyright © 2008 - 2020 RV LIFE. All Rights Reserved.
</br></br>
This post may contain affiliate links</p><div class="social-footer"><div id="nav_menu-7" class="widget-odd widget-last widget-first widget-1 legal-menu widget_nav_menu"><div class="menu-below-copyright-menu-container"><ul id="menu-below-copyright-menu" class="menu"><li id="menu-item-56727" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56727"><a href="https://rvlife.com/terms-of-service/">Terms of Service</a></li>
<li id="menu-item-56728" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56728"><a href="https://rvlife.com/privacy-statement/">Privacy Policy</a></li>
<li id="menu-item-56729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56729"><a href="https://rvlife.com/contact/">Contact</a></li>
<li id="menu-item-62826" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62826"><a href="https://rvlife.com/disclaimer/">Disclaimer</a></li>
</ul></div></div></div></div></footer></div>	<script type='text/javascript'>
	/* <![CDATA[ */
	var js_i18n = {"next":"next","back":"Back"};
	/* ]]> */
	</script>
<!-- Custom Facebook Feed JS -->
<script type="text/javascript">
var cfflinkhashtags = "true";
</script>
<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://rvlife.com/wp-admin/admin-ajax.php";
</script>
<div id="mashbar-header">
                        <div class="mashbar-inner">
                        <div class="mashbar-logo"><a href="/"> 
                        <span class="desktop"><img alt="Logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://rvlife.com/wp-content/uploads/2019/09/mash-logo-lg.png"><noscript><img alt="Logo" src="https://rvlife.com/wp-content/uploads/2019/09/mash-logo-lg.png"></noscript></span>
                        <span class="mobile"><img alt="Mobile Logo" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://rvlife.com/wp-content/uploads/2019/09/mash-logo-sm.png"><noscript><img alt="Mobile Logo" src="https://rvlife.com/wp-content/uploads/2019/09/mash-logo-sm.png"></noscript></span>
                </a></div><aside class="mashsb-container mashbar mashsb-stretched"><div class="mashsb-box"><div class="mashsb-count"><div class="counts mashsbcount">25</div><span class="mashsb-sharetext">SHARES</span></div><div class="mashsb-buttons"><div class="mashpv mashsb-count mash-large" data-mashpv-postid="63130" data-mashtip="This number shows the total pageviews since publishing of the article"><div class="count">4.7k</div><span class="mashsb-sharetext">VIEWS</span></div><a class="mashicon-facebook" href="https://www.facebook.com/sharer.php?u=https://rvlife.com/hummer-ev/" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Facebook</span></a><a class="mashicon-twitter" href="https://twitter.com/intent/tweet?text=Will+The+Hummer+EV+Be+The+New+Favorite+For+RVers%3F&via=rvlifemagazine&url=https://rvlife.com/hummer-ev/" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Twitter</span></a><div class="onoffswitch mash-large mashsb-noshadow"></div><div class="secondary-shares" style="display:none;"><a class="mashicon-mail" href="mailto:?subject=Will The Hummer EV Be The New Favorite For RVers?&body=Very%20interesting%20article:%20https://rvlife.com/hummer-ev/" target="_blank" rel="nofollow"><span class="icon"></span><span class="text">Email</span></a><div class="onoffswitch mash-large mashsb-noshadow"></div><div class="secondary-shares" style="display:none;"><div class="onoffswitch2 mash-large mashsb-noshadow" style="display:none;"></div></div></div></div>
                    <div style="clear:both;"></div><div class="mashsb-toggle-container"></div></aside>
                        <!-- Share Bar by mashshare.net - Version: 1.4.9--></div></div>	<div style="display:none">
	<div class="grofile-hash-map-ed532b8c60fc99d551af30cc9c219dd5">
	</div>
	<div class="grofile-hash-map-2f660a9beecedcea7c5076d770e0fa1f">
	</div>
	<div class="grofile-hash-map-86b942d807e182b1fdd4d9d188f753be">
	</div>
	<div class="grofile-hash-map-ba7756dd7721e9eb4cbb036c645bdc6b">
	</div>
	<div class="grofile-hash-map-8119867ca8adfaf8be30cd07522ea1c5">
	</div>
	</div>
<!-- This site is converting visitors into subscribers and customers with OptinMonster - https://optinmonster.com :: Campaign Title: RV LIFE v2 Elegant --><script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-campaign="s11mtry8rb0powbk298e" data-user="17189"></script><!-- / OptinMonster -->		<script type="text/javascript">var s11mtry8rb0powbk298e_shortcode = true;</script>
		<style type="text/css">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</style><script type='text/javascript' src='https://rvlife.com/wp-content/plugins/custom-facebook-feed/js/cff-scripts.js?ver=2.17'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=202043'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Octaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.2.7'></script>
<script type='text/javascript' src='https://rvlife.com/wp-includes/js/comment-reply.min.js?ver=5.2.7'></script>
<script type='text/javascript' src='https://rvlife.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.1.2'></script>
<script type='text/javascript' src='https://rvlife.com/wp-content/themes/milan/js/navigation.js?ver=1.1.0'></script>
<script type='text/javascript' src='https://rvlife.com/wp-includes/js/wp-embed.min.js?ver=5.2.7'></script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/jetpack/_inc/build/spin.min.js?ver=1.3'></script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/jetpack/_inc/build/jquery.spin.min.js?ver=1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/rvlife.com\/wp-admin\/admin-ajax.php","nonce":"7bc41726da","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/rvlife.com\/wp-login.php?redirect_to=https%3A%2F%2Frvlife.com%2Fhummer-ev%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=20190102'></script>
<script async="async" type='text/javascript' src='https://rvlife.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6'></script>
<script type='text/javascript' src='https://rvlife.com/wp-content/plugins/optinmonster/assets/js/helper.js?ver=1.9.9'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202043.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:7.7.3',blog:'85981658',post:'63130',tz:'-5',srv:'rvlife.com'} ]);
	_stq.push([ 'clickTrackerInit', '85981658', '63130' ]);
</script>
		<script type="text/javascript">var omapi_localized = { ajax: 'https://rvlife.com/wp-admin/admin-ajax.php?optin-monster-ajax-route=1', nonce: '8be29970e4', slugs: {"s11mtry8rb0powbk298e":{"slug":"s11mtry8rb0powbk298e","mailpoet":false}} };</script>
				<script type="text/javascript">var omapi_data = {"wc_cart":[],"object_id":63130,"object_key":"post","object_type":"post","term_ids":[97,98,473,29778,21966,29779,29780,453,863]};</script>
		<script>window.lazyLoadOptions = {
                elements_selector: "img[data-lazy-src],.rocket-lazyload",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 300,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                }};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;

            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;

                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );

                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };

                observer.observe(b, config);
            }
        }, false);</script><script data-no-minify="1" async src="https://rvlife.com/wp-content/plugins/rocket-lazy-load/assets/js/12.0/lazyload.min.js"></script></body></html>
